Index  •  FAQ  •  Search   •   Register | Login  

It is currently Sun Nov 18, 2018 5:47 am


Last visit was: style=

Post new topic Reply to topic  [ 10 posts ] 
 TS12 SP1 multiple issues 
Author Message
 Post subject: TS12 SP1 multiple issues
PostPosted: Fri May 22, 2015 5:59 pm 
Past 750!
User avatar

Joined: Wed Jul 11, 2012 8:08 pm
Posts: 972
Location: Southampton, England
Trainz Version: TS12
Trainz Build: 49922
Author KUID: 688183
Hi, I have a couple of problems with my TS12 SP1 installation (patched to 61388), and was hoping someone could help me sort them out, since I do miss some of the features SP1 added to plain old 49922...

First of, the performance is absolutely appalling! Opening up the same route in the same position, running with unpatched TS12 (build 49922) I get around 40-50fps, with SP1 I'm down to 9! I know as newer features are added the performance might suffer a little, but to be down 30fps from a service pack is excessive! Even a blank baseboard only gives me 35fps...

Secondly, it also seems to just stop randomly. As in, the program will just lock up and go whited out with with the dialog box that "Trainz is not responding". At this point the only thing to do is to kill it in task manager and face an EDR next time it starts up. This happens fairly randomly, but usually occurs after between 30 minutes to an hour of use. CMP is not safe from this either, it too will just stop responding randomly. Checking the database processes, Trainzutil appears to begin validating, but then just stop half way through, the window just showing:
Code:
CommandHostCallback> TAD_CMDHOST_VALIDATE
And Taddaemon just says:
Code:
AssetIndex::WriteDatabase


If anyone could help with these issues, I would be very grateful. Until then, I guess I'll be sticking with 49922.

Thanks,
James

_________________
James M, creator of the
Image
network


Offline
 Profile  
 
 Post subject: Re: TS12 SP1 multiple issues
PostPosted: Sat May 23, 2015 12:01 am 
Past 250!
User avatar

Joined: Sat Dec 18, 2010 1:40 pm
Posts: 345
Location: Cambridgeshire
Trainz Version: 06/TC3/09/10/12/TANE
Trainz Build: 4
Author KUID: 243828
I have been running 61388 ever since it came out with no problems.

The best I can suggest is to try another install and see if that helps.

There may also be some issues round your physical PC build.

Also, as TS12 gradually moved towards TANE and standards have got more rigid older assets could be a bigger performance drag on the system. Have you tried turning on Performance Statistics ? OK most of us don't have a clue what they mean but big changes in numbers between versions would point to a problem.

Chris

_________________
Image

http://itareustrainz.weebly.com/


Offline
 Profile  
 
 Post subject: Re: TS12 SP1 multiple issues
PostPosted: Sat May 23, 2015 2:09 pm 
Past 750!
User avatar

Joined: Wed Jul 11, 2012 8:08 pm
Posts: 972
Location: Southampton, England
Trainz Version: TS12
Trainz Build: 49922
Author KUID: 688183
Thanks for the suggestions, I've tried reinstalling, and the problems seem to persist...


I have attached the performance statistics for both 61388 and 49922, they don't look too different:

61388, I was getting around 8-9fps when this shot was taken:
Image

49922, same area, around 30fps
Image

From what I can tell, 49922 appears to be more heavily loaded down than 61388 (higher scene load), but I'm not sure what any of these numbers mean so it probably doesn't help...

As for my PC build, it's getting a little long in the tooth but still seems to be capable of running everything else satisfactorily:
- Intel Xeon X3220 2.4GHz quad core running at 3.2GHz
- Gigabyte P45 Motherboard
- 8GB DDR2 800MHz RAM
- XFX Radeon HD 6870
- 500+750GB WD/Seagate HDDs

_________________
James M, creator of the
Image
network


Offline
 Profile  
 
 Post subject: Re: TS12 SP1 multiple issues
PostPosted: Sat May 23, 2015 3:13 pm 
Forum Veteran

Joined: Sun Dec 12, 2010 3:16 pm
Posts: 1279
Location: Crewe, Cheshire, UK
Trainz Version: TRS19
Trainz Build: 96000
Author KUID: 425700
Try a defrag on the drive 61388 is on? i assume you have done the usual QDR which often fixes poor performance for some obscure reason. Yes 61388 has lower frame rates than 49922 here but not that big a difference only talking maybe 5 fps lower.


Offline
 Profile  
 
 Post subject: Re: TS12 SP1 multiple issues
PostPosted: Sat May 23, 2015 10:33 pm 
Forum Veteran
User avatar

Joined: Mon Mar 31, 2014 6:41 pm
Posts: 1316
Location: West Midlands
Trainz Version: 2006 2012 T:ANE SP3
Trainz Build: 94916
Author KUID: 214658
Would there be any particular clue in the massive difference in UDP packets, Malc? (61388 - 2ppm whereas 49922 is up at 30ppm) I know UDP is an alternative to TCP but I'm not that clued up as to why UDP would be used here.

Dave


Offline
 Profile  
 
 Post subject: Re: TS12 SP1 multiple issues
PostPosted: Sat May 23, 2015 11:35 pm 
Forum Veteran

Joined: Sun Dec 12, 2010 3:16 pm
Posts: 1279
Location: Crewe, Cheshire, UK
Trainz Version: TRS19
Trainz Build: 96000
Author KUID: 425700
cyberdonblue wrote:
Would there be any particular clue in the massive difference in UDP packets, Malc? (61388 - 2ppm whereas 49922 is up at 30ppm) I know UDP is an alternative to TCP but I'm not that clued up as to why UDP would be used here.

Dave

Now there's an interesting find, UDP dispenses with error checking that TCP does so in theory is faster but doesn't bother to check if a packet has been received. As far as I was aware Trainz just uses TCP, just checked on my monitoring stuff and it does not appear to be using UDP, just TCP.


Offline
 Profile  
 
 Post subject: Re: TS12 SP1 multiple issues
PostPosted: Sun May 24, 2015 10:01 am 
Forum Veteran
User avatar

Joined: Mon Mar 31, 2014 6:41 pm
Posts: 1316
Location: West Midlands
Trainz Version: 2006 2012 T:ANE SP3
Trainz Build: 94916
Author KUID: 214658
But what is baffling me is, why would network transmission protocols get involved if James is just playing the game on his PC?

Dave


Offline
 Profile  
 
 Post subject: Re: TS12 SP1 multiple issues
PostPosted: Sun May 24, 2015 12:35 pm 
Forum Veteran

Joined: Sun Dec 12, 2010 3:16 pm
Posts: 1279
Location: Crewe, Cheshire, UK
Trainz Version: TRS19
Trainz Build: 96000
Author KUID: 425700
In addition to contacting the DLS, DRM server and chat if you use it, Trainz uses TCP internally, presumably something relating to the database handling, mostly its connecting to the loopback IP

TS12 SP1 does have a rather suspicious connection to google analytics though.

Quote:
taddaemon.exe 3344 TCP 49286 192.168.1.101 80 http 74.125.136.138 www-google-analytics.l.google.com Established g:\ts12 - 61388\bin\taddaemon.exe


Closing the TCP connection just cause it to restart using a different IP
blocking it in hosts doesn't work for the same reason........

Also looks like they are using a Europe based sever for something? Trainz.exe is connected to c.global-ssl.fastly.net which is in London , hmm while typing this and watching the connections on the other PC fastly.net has disappeared.


Offline
 Profile  
 
 Post subject: Re: TS12 SP1 multiple issues
PostPosted: Sun May 24, 2015 2:37 pm 
Forum Veteran
User avatar

Joined: Sun Dec 12, 2010 3:02 pm
Posts: 2637
Location: West Midlands
Trainz Version: TANE
Trainz Build: 94916
Author KUID: 45317
TANE has a download server in London is it the same one ?

_________________
High visibility pixels must be worn when on or about the line !!


Offline
 Profile  
 
 Post subject: Re: TS12 SP1 multiple issues
PostPosted: Sun May 24, 2015 3:29 pm 
Forum Veteran

Joined: Sun Dec 12, 2010 3:16 pm
Posts: 1279
Location: Crewe, Cheshire, UK
Trainz Version: TRS19
Trainz Build: 96000
Author KUID: 425700
Not sure what it is, DRM server? Or maybe something to do with Softlayer/Ex Theplanet/ now IBM which last time I looked were bragging about server farms all over the Globe.


Offline
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 


 Who is online 

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

 
Index  |  FAQ  |  Search

phpBB skin developed by: John Olson
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group