Index  •  FAQ  •  Search   •   Register | Login  

It is currently Sat Sep 22, 2018 3:36 pm


Last visit was: style=

Post new topic Reply to topic  [ 7 posts ] 
 Missing dependencies showing up even when not in config file 
Author Message
 Post subject: Missing dependencies showing up even when not in config file
PostPosted: Sun May 22, 2016 9:23 pm 
Milepost 5

Joined: Fri Dec 17, 2010 2:57 pm
Posts: 63
Location: Surrey, BC, Canada
Trainz Version: TS12 & TANE
Trainz Build: 0
Author KUID: 0
Hello all,
Need a wee bit o' help please. In TZ2012 I have a route which was started way back in TZ2006, moved to TZ2010, and I am now working again on it in TZ2012.
However it keeps showing up as missing dependencies in Content Manager, but when you look in the config file none of the dependencies are even listed in the file....
All of them were scenery items (trees) which I replaced with new ones which I had in the TZ2012 database.

Can anyone tell me why these items still list as dependencies and where I need to look/do to remove them?

Any suggestions are appreciated
Thanks
Michael


Offline
 Profile  
 
 Post subject: Re: Missing dependencies showing up even when not in config
PostPosted: Sun May 22, 2016 11:29 pm 
Forum Veteran

Joined: Sun Dec 12, 2010 3:16 pm
Posts: 1248
Location: Crewe, Cheshire, UK
Trainz Version: TRS19
Trainz Build: 96000
Author KUID: 425700
In the route delete missing assets may work?


Offline
 Profile  
 
 Post subject: Re: Missing dependencies showing up even when not in config
PostPosted: Mon May 23, 2016 3:22 am 
Milepost 5

Joined: Fri Dec 17, 2010 2:57 pm
Posts: 63
Location: Surrey, BC, Canada
Trainz Version: TS12 & TANE
Trainz Build: 0
Author KUID: 0
Tried that to no avail.


Offline
 Profile  
 
 Post subject: Re: Missing dependencies showing up even when not in config
PostPosted: Mon May 23, 2016 12:48 pm 
Forum Veteran

Joined: Sun Dec 12, 2010 3:16 pm
Posts: 1248
Location: Crewe, Cheshire, UK
Trainz Version: TRS19
Trainz Build: 96000
Author KUID: 425700
Try save as an save as a new route or if that doesn't work, clone the route in CM?


Offline
 Profile  
 
 Post subject: Re: Missing dependencies showing up even when not in config
PostPosted: Sat May 28, 2016 2:58 pm 
Milepost 5

Joined: Fri Dec 17, 2010 2:57 pm
Posts: 63
Location: Surrey, BC, Canada
Trainz Version: TS12 & TANE
Trainz Build: 0
Author KUID: 0
Thanks for the suggestion. Didn't work either.

I am now going back to TZ2010 to clean up the route and then try another move to 2012.

Thanks
Michael


Offline
 Profile  
 
 Post subject: Re: Missing dependencies showing up even when not in config
PostPosted: Sun May 29, 2016 4:52 pm 
Milepost 5

Joined: Fri Dec 17, 2010 2:57 pm
Posts: 63
Location: Surrey, BC, Canada
Trainz Version: TS12 & TANE
Trainz Build: 0
Author KUID: 0
Ok - got it sorted.

Even if you remove the missing dependencies in the route file those dependencies seem to still be remembered through the session file. So when moving from 2010 to 2012 I needed to move ONLY the route file and not any session files.
It would also appear from other testing on a different route that the "remove missing dependencies" function in the main menu does not work properly. I deleted to kuids (available on DLS) from my database and then open a route where they were used asking to have missing dependencies removed. Nothing happened - well, the system spent time, but nothing other happened. When It tried to save the route I was told by 2012 that there were no changes made.... Go figure.

Glad I kept my 2010 installed. That allowed me to clean up. Bit of work but now good.

Michael


Offline
 Profile  
 
 Post subject: Re: Missing dependencies showing up even when not in config
PostPosted: Mon May 30, 2016 8:13 am 
Milepost 5
User avatar

Joined: Tue Sep 22, 2015 4:51 am
Posts: 74
Location: From Warwickshire, England
Trainz Version: 12 SP1
Trainz Build: 61388
Author KUID: 102457
Hi, Just a thought maybe the route cannot find the kuid update properly when displaying in TS 12 content manager.
For example an old kuid in TS2006 may be Kuid:12345:10009 and in the Trainz 12 an update kuid2:12345:10009:5 might be available.
Sometimes content manager cannot find the 5th update because the 4th is not on the dls.
In content manager when you search the base asset 12345:10009 click on the tab to see all versions available then download the latest update.
In some of the dependant assets kuid table may need to be updated to recognise the kuid2:12345:10009:5


Offline
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 


 Who is online 

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

 
Index  |  FAQ  |  Search

phpBB skin developed by: John Olson
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group