Index  •  FAQ  •  Search   •   Register | Login  

It is currently Thu Dec 13, 2018 9:16 pm


Last visit was: style=

Post new topic Reply to topic  [ 9 posts ] 
 TS12 won't start after GPU driver update 
Author Message
 Post subject: TS12 won't start after GPU driver update
PostPosted: Sun Apr 16, 2017 4:41 pm 
Past 750!
User avatar

Joined: Wed Jul 11, 2012 8:08 pm
Posts: 975
Location: Southampton, England
Trainz Version: TS12
Trainz Build: 49922
Author KUID: 688183
Hi everyone, I've got an annoying problem with my TS12 installation (again, I seem to project a field that causes nearby computers to malfunction! :lol: )

Basically, Radeon Settings decided to update my GPU drivers, and now TS12 will not start. I just get the "Your hardware or software is unable to communicate correctly with Trainz." message, and in the options dialog, no resolution options are able to be selected (the box is blank).

Image

I have tried uninstalling and reinstalling the GPU drivers with DDU, and reinstalling Trainz. Now, when I run TrainzDiag, It produces the following screen:

Image

and the same thing happens - I cannot select any resolution and am unable to run Trainz.

My specs are below:
Intel Core i5-2400 (3.1GHz, running at 3.3GHz)
ASUS P8H67-V Motherboard
16GB DDR3-1600 RAM
AMD Radeon RX 480 (8GB)
ADATA SU800 128GB SSD (OS drive)
ADATA SU800 256GB SSD (Trainz drive)

Is there anything else I can try, short of reinstalling Windows?

_________________
James M, creator of the
Image
network


Offline
 Profile  
 
 Post subject: Re: TS12 won't start after GPU driver update
PostPosted: Sun Apr 16, 2017 8:37 pm 
Past 500!
User avatar

Joined: Sun Dec 12, 2010 5:27 pm
Posts: 655
Location: Lincoln
Trainz Version: Tane
Trainz Build: 94916
Author KUID: 222042
check which version of Direct X is running, the update may have uninstalled direct X 10 & replaced it with 11.
If so, you will have to manually download & install the earlier version.

I think this may be the problem, as it rings a bell from something in the n3v forum.

_________________
Tane SP3 build 94916 + SnC & Duchess


Offline
 Profile  
 
 Post subject: Re: TS12 won't start after GPU driver update
PostPosted: Tue Apr 18, 2017 12:06 am 
Past 750!
User avatar

Joined: Wed Jul 11, 2012 8:08 pm
Posts: 975
Location: Southampton, England
Trainz Version: TS12
Trainz Build: 49922
Author KUID: 688183
Thank you, for the reply, I believe I have all 3 DirectX (9, 10 and 11) versions installed (I installed them again just to make sure)

I did manage to fix the issue though, turns out I needed to roll back to the old drivers in a very specific way:

  • Uninstall Trainz
  • Uninstall GPU drivers
  • Reboot
  • Install Trainz
  • Reboot
  • Patch to build 49922
  • Reboot
  • Install old GPU drivers
  • Reboot
  • Run Trainz, copy content over and perform QDR
  • Reboot

After that, all was fixed and TS12 started up fine. Oddly no other combination of installation worked (If I installed the old drivers before Trainz or applying the patch, it would still be broken, as well as following the above steps but using the newer drivers), so I don't really know what was actually broken, but it all seems to be working now... I guess I just won't update my graphics drivers no mater how much Radeon Settings complains!

_________________
James M, creator of the
Image
network


Offline
 Profile  
 
 Post subject: Re: TS12 won't start after GPU driver update
PostPosted: Tue Apr 18, 2017 10:14 am 
Past 500!
User avatar

Joined: Sun Dec 12, 2010 5:27 pm
Posts: 655
Location: Lincoln
Trainz Version: Tane
Trainz Build: 94916
Author KUID: 222042
Glad you got it fixed, but what a ball ache.

What graphics card do you have?
I have a Radeon R9 200 series & have not had any update issues with it, although I did with
my previous card, an Nvidia GT9800, had to roll back drivers for that card on a few occasions.

_________________
Tane SP3 build 94916 + SnC & Duchess


Offline
 Profile  
 
 Post subject: Re: TS12 won't start after GPU driver update
PostPosted: Tue Apr 18, 2017 2:18 pm 
Past 750!
User avatar

Joined: Wed Jul 11, 2012 8:08 pm
Posts: 975
Location: Southampton, England
Trainz Version: TS12
Trainz Build: 49922
Author KUID: 688183
Its a Radeon RX 480, first time I've had any problems with Trainz and updating drivers too, and I've been through a fair few graphics cards!

_________________
James M, creator of the
Image
network


Offline
 Profile  
 
 Post subject: Re: TS12 won't start after GPU driver update
PostPosted: Tue Apr 18, 2017 3:53 pm 
Forum Veteran

Joined: Sun Dec 12, 2010 3:16 pm
Posts: 1290
Location: Crewe, Cheshire, UK
Trainz Version: TRS19
Trainz Build: 96000
Author KUID: 425700
First Question what Operating System?
TS12 requires DX9c not 10 or 11 or 12. so you have to add it or it either won't work or if it does runs like a dead slug.


Offline
 Profile  
 
 Post subject: Re: TS12 won't start after GPU driver update
PostPosted: Tue Apr 18, 2017 8:27 pm 
Past 750!
User avatar

Joined: Wed Jul 11, 2012 8:08 pm
Posts: 975
Location: Southampton, England
Trainz Version: TS12
Trainz Build: 49922
Author KUID: 688183
Windows 7 (Professional 64-bit). I had already installed DX9 before the driver update, and reinstalled it again after I started having problems

_________________
James M, creator of the
Image
network


Offline
 Profile  
 
 Post subject: Re: TS12 won't start after GPU driver update
PostPosted: Tue Apr 18, 2017 10:07 pm 
Forum Veteran

Joined: Sun Dec 12, 2010 3:16 pm
Posts: 1290
Location: Crewe, Cheshire, UK
Trainz Version: TRS19
Trainz Build: 96000
Author KUID: 425700
Tried rolling back the driver in device manager?


Offline
 Profile  
 
 Post subject: Re: TS12 won't start after GPU driver update
PostPosted: Thu Apr 20, 2017 2:47 am 
Past 750!
User avatar

Joined: Wed Jul 11, 2012 8:08 pm
Posts: 975
Location: Southampton, England
Trainz Version: TS12
Trainz Build: 49922
Author KUID: 688183
Yeah, I'm currently back on 17.2.1 - following the procedure I described above with this version worked. Just rolling back in the usual way, or using any newer drivers with the above procedure caused the failures. I tried 17.4.1 (fail), 17.3.3 (fail), 17.2.1 (worked as above), and 17.1.2 (also worked but 17.2.1 gave better performance).

_________________
James M, creator of the
Image
network


Offline
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 


 Who is online 

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

 
Index  |  FAQ  |  Search

phpBB skin developed by: John Olson
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group