Index  •  FAQ  •  Search   •   Register | Login  

It is currently Mon Aug 21, 2017 7:20 am


Last visit was: style=

Post new topic Reply to topic  [ 4 posts ] 
 Changes not saving to route 
Author Message
 Post subject: Changes not saving to route
PostPosted: Tue Aug 08, 2017 5:19 pm 
Forum Veteran
User avatar

Joined: Mon Dec 13, 2010 4:12 pm
Posts: 1207
Trainz Version: T:ANE
Trainz Build: 78667
Author KUID: 0
I've encountered a strange new issue (for me at least) when it comes to saving work to a route. Although I start in 'edit route' when I save it and leave the route, next time I open under 'edit route' the changes are gone. However, if I look in the sessions, the changes still exist there.

I've tried merging the session into the route to fix it but it still doesn't seem to have any effect. Any ideas folks?

Cheers,
Innis

_________________
Meetings. None of us is dumb as all of us.


Offline
 Profile  
 
 Post subject: Re: Changes not saving to route
PostPosted: Tue Aug 08, 2017 10:18 pm 
Site Admin
User avatar

Joined: Sun Dec 12, 2010 2:57 pm
Posts: 858
Location: Nr Penryn, Cornwall
Trainz Version: TS2010
Trainz Build: 44088
Author KUID: 179051
Sounds like you are building onto the session layer rather than the route layer.

Mark

_________________
Image

My Flickr: http://www.flickr.com/photos/66901380@N04/


Offline
 Profile  
 
 Post subject: Re: Changes not saving to route
PostPosted: Wed Aug 09, 2017 12:45 am 
Past 750!
User avatar

Joined: Mon Mar 31, 2014 7:41 pm
Posts: 997
Location: West Midlands
Trainz Version: 2006 2012 T:ANE SP1
Trainz Build: 84204
Author KUID: 214658
Apparently there have been some big changes to how everything gets saved. I don't really understand it properly - and I'm not a great fan of the new way, to say the least.

Your route is actually "Open for Edit" while you're working on it and if you're not careful you can end up with hundreds of session copies of the same thing. Whilst I'm working on my WIP, I save to the route layer but put a tick in the box NOT to save the session. Then when I'm ready to shut down I do the same again followed by clicking on "exit Surveyor." T:ANE then asks if I want to save the session. "Over write previous session" (or something like that) is usually already ticked in the box and I just accept the option. This means that I now only have my route and one "Default" copy instead of half a million "Default" copies.

Hope that helps a little bit Innis.

Cheers

Dave


Offline
 Profile  
 
 Post subject: Re: Changes not saving to route
PostPosted: Wed Aug 09, 2017 8:49 pm 
Forum Veteran
User avatar

Joined: Mon Dec 13, 2010 4:12 pm
Posts: 1207
Trainz Version: T:ANE
Trainz Build: 78667
Author KUID: 0
I stared editing a route. I never opened a session as I always work on the route or base layer. I went back to the route and discovered everything was saved to the session layer somehow and now I can't get the edits down to the route layer. I thought that's what merge layers was meant to do or have I totally misunderstood. I've also tried saving it as a totally new route but again, nothing saves to the base layer.

***EDIT***

Thanks guys, I had another go at merging it and it seems to have worked now. Maybe it was user error? :|

_________________
Meetings. None of us is dumb as all of us.


Offline
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 


 Who is online 

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

 
Index  |  FAQ  |  Search

phpBB skin developed by: John Olson
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group